GNS3 on Debian GNU/Linux

This page describes installation of GNS3 version 2.1.2 on Debian GNU/Linux, in my case it is release testing.

Installation

  1. Add to sources.list
    deb http://ppa.launchpad.net/gns3/ppa/ubuntu/ zesty main
  2. Update the packages list index
    # apt-get update
  3. Install gns3-gui and gns3-server
    # apt-get install gns3-gui gns3-server

Workaround

  • Check symlink of python binary
    # ln -s /usr/bin/python
  • GNS3 uses Python 3, so Python binary should link to python3. If not, create symlink to python3
    # ln -s /usr/bin/python3 /usr/bin/python

    First you need to remove the old symlink to python2

  • Go to /usr/share/gns3/gns3-gui
    # cd /usr/share/gns3/gns3-gui/
  • Run source to activate virtualenv
    # source bin/activate
  • Install gns3-gui from pip
    # pip install gns3-gui
  • Install PyQt5 including PyQt5-sip from pip
    # pip install PyQt5

Error messages

  • No gns3-gui lib
    Traceback (most recent call last):
      File "/usr/bin/gns3", line 6, in <module>
        from pkg_resources import load_entry_point
      File "/usr/share/gns3/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3019, in <module>
        @_call_aside
      File "/usr/share/gns3/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3003, in _call_aside
        f(*args, **kwargs)
      File "/usr/share/gns3/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3032, in _initialize_master_working_set
        working_set = WorkingSet._build_master()
      File "/usr/share/gns3/lib/python3.6/site-packages/pkg_resources/__init__.py", line 655, in _build_master
        ws.require(__requires__)
      File "/usr/share/gns3/lib/python3.6/site-packages/pkg_resources/__init__.py", line 963, in require
        needed = self.resolve(parse_requirements(requirements))
      File "/usr/share/gns3/lib/python3.6/site-packages/pkg_resources/__init__.py", line 849, in resolve
        raise DistributionNotFound(req, requirers)
    pkg_resources.DistributionNotFound: The 'gns3-gui==2.1.2' distribution was not found and is required by the application
  • PyQt5-sip lib needs to be updated
    Fail update installation: the sip module implements API v12.0 to v12.3 but the PyQt5.QtCore module requires API v12.5
    Traceback (most recent call last):
      File "/usr/local/bin/gns3", line 7, in <module>
        from gns3.main import main
      File "/usr/local/lib/python3.6/dist-packages/gns3/main.py", line 52, in <module>
        from gns3.qt import QtCore, QtWidgets
      File "/usr/local/lib/python3.6/dist-packages/gns3/qt/__init__.py", line 36, in <module>
        from PyQt5 import QtCore, QtGui, QtNetwork, QtWidgets, Qt
    RuntimeError: the sip module implements API v12.0 to v12.3 but the PyQt5.QtCore module requires API v12.5
 
doc/gns3-deb.txt · Last modified: 2018/12/18 03:27 by stwn · [Old revisions]
Recent changes RSS feed Powered by PHP Valid XHTML 1.0 Valid CSS Driven by DokuWiki